I'm having difficulty loading the fulfillment page in order to review purchase orders

  • 1
  • Problem
  • Updated 1 year ago
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members. The community moderator provided the following reason for archiving: SF case created - 03528124

I  login to SPS commerce and click the fulfillment tab to look at my purchase orders.  The screen goes completely blank and nothing loads.  I'm unable to load any orders.  My company name is L and F Distributors and the account is setup under steven.koen@favoritebrands.org
Not sure what steps to take in order to make this work, so I've done nothing.
Photo of Bryan Baeten

Bryan Baeten

  • 90 Points 75 badge 2x thumb

Posted 1 year ago

  • 1
Photo of Randall Carlson

Randall Carlson

  • 120 Points 100 badge 2x thumb
What web browser are you using? I have experienced different browsers will not load.. try a different browser if you can...
Photo of Bryan Baeten

Bryan Baeten

  • 90 Points 75 badge 2x thumb
I've used the exact same web browser week after week to fulfill purchase orders.  Unless something recently changed with SPS accessibility in Microsoft Edge, I don't think that's the problem.
Photo of Ryan Morrissey

Ryan Morrissey, Employee

  • 1,646 Points 1k badge 2x thumb
Bryan,

Randall's suggestion is a good one; we typically recommend customers use Google Chrome to access Fulfillment; it is extremely compatible with the Fulfillment portal. You may want to try clearing your history and temporary internet files within the browser you are using as well.

If you are still unable to access the Fulfillment portal, please contact our Support team at 888.739.3232.

-Ryan
Photo of Bryan Baeten

Bryan Baeten

  • 90 Points 75 badge 2x thumb
The same problem is happening to me regardless of the browser I use.

This conversation is no longer open for comments or replies.