I cannot print POs to a single page

  • 4
  • Problem
  • Updated 5 years ago
  • Solved
  • (Edited)
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members. The community moderator provided the following reason for archiving: Old

I am having a problem when printing our Wayfair webform purchase orders. It seems like the format has changed. What used to fit on one page now spills over to two and it is really unnecessary. I have tried every setting I can think of to get it to print like it used to (last week) but can't get it back to what it used to be. It seems like the Freight Terms, Shipping Speed, Terms Type, Terms Basic etc. cells are now too big and won't compress or spread across the page, the margins are at least 1 inch either side. Also it seems that changes have been made to the header. The web address used to print on the bottom and it now comes up on the very top of the page, then there is about an inch space before the rest of the print begins.
We would like our purchase orders to be only one page again! I have contacted our Wayfair contact who assures me they haven't updated or changed their pages and suggested I contact you. I was on hold for nearly 10 minutes on the SPS Customer service line earlier and was not able to speak with a single person! Please help!
Photo of Pip

Pip

  • 110 Points 100 badge 2x thumb
  • frustrated

Posted 6 years ago

  • 4
Photo of Pat

Pat, Sr. Customer Operations Analyst

  • 690 Points 500 badge 2x thumb
Hello Pip! I apologize that your POs are printing on multiple pages rather than one. I believe that this issue is only experienced when using Mozilla Firefox. I was able to print an example PO to one page from Internet Explorer. Having said that, my suggestion would be to download and install the IE Tab Plus add-on within Firefox

1. You can download the IE Tab Plus by following this link:

2. Click the big green button on this page entitled “Add to Firefox”
href="s3_images/885743/FFSSP02_jpg.jpg?1365714110">

3. Click “Install Now” on the software installation window


4. Click “Restart Firefox” in the Add-ons window


5. When Firefox restarts, select “Basic Mode” from the IE Tab Plus Options window


6. Right-click the tab that contains the Stylesheet you are trying to print and select “Switch Rendering Engine”


After following these steps, you should be able to print the POs as you did previously. Please do let me know if this does not resolve your issue and I would be happy to troubleshoot over the phone.

I look forward to hearing from you soon!
Photo of Pip

Pip

  • 110 Points 100 badge 2x thumb
Awesome Pat!! Thanks so much. I completely forgot that I had switched to Mozilla! I will apply the solution and let you know how I get on. Appreciate your help. :)
Photo of Pat

Pat, Sr. Customer Operations Analyst

  • 690 Points 500 badge 2x thumb
That's great news! Please let me know if you run into any similar issues in the future.
Photo of Dana

Dana

  • 82 Points 75 badge 2x thumb
I am using Mozilla Firefox and having a problem printing PO's. For example, I have one purchase order that is 11 pages but when I print, only the first page and last page print, and it says page 1 of 2. All the middle pages disappear. Printer settings seem fine. Printing from Explorer works but other issues with IE makes MF the better browser except for this printing issue.

This reply was created from a merged topic originally titled
PO's not printing correctly from Mozilla Firefox.
Photo of Dana

Dana

  • 82 Points 75 badge 2x thumb
Hi Pat.

I downloaded the add on per the link you provided above. They have changed it abit...now you only have two choices: classic or advanced. I went with classic :)

I have my tab up that displays the PO, right click on the tab, chose "switch rendering engine" and now I just get a blank page! Maybe I should go back to IE and try to remember what was problematic with that browser! :p I'm in a new position, new to SPS ( only 2 weeks in) so I'm working on getting all my programs to run smoother...
Photo of Dana

Dana

  • 82 Points 75 badge 2x thumb
I got it to work with some extra playing around. I used a different, (more recent) version of IE Tabs that you suggested above. I used IE Tab V2 at : https://addons.mozilla.org/en-US/fire....

This fixed the problem of getting the blank page and now my printing is working :)
Photo of Iveta Valterova

Iveta Valterova

  • 62 Points
Photo of Lisa Sacquitne

Lisa Sacquitne, Product Manager

  • 2,358 Points 2k badge 2x thumb
Hi Iveta, Please review this post and let us know if you have any further questions!
Photo of Christina Wales

Christina Wales

  • 656 Points 500 badge 2x thumb
The extension I'm using to resolve the problem Dana had is Fire IE. It is compatible with the most recent versions of Firefox, but still includes cookie sync. I added auto-switch rules for SPS Commerce and the other portals I use that are not Firefox friendly, and now I don't have to mess with switching browsers or even clicking to toggle within the tab.

https://addons.mozilla.org/en-US/fire...
Photo of Renee

Renee

  • 122 Points 100 badge 2x thumb
Photo of Hannah

Hannah, Alum

  • 2,370 Points 2k badge 2x thumb
Good morning Renee! I believe you will find helpful troubleshooting tips in this post. If any issues persist, please let us know.

Have a great day!
Photo of Renee

Renee

  • 122 Points 100 badge 2x thumb
Not seeing anything that would help. I want to turn off the extra cover page that prints. It is a waste of paper that prints everytime we print orders from this site. I am using IE.
Photo of Hannah

Hannah, Alum

  • 2,370 Points 2k badge 2x thumb
Hi Renee--

If you have already run through preliminary troubleshooting steps like Clearing Temporary Internet Files & Java cache, as well as setting your printer as the default printer on your computer, you may also try selecting "All frames individually" on the Options tab of your Printer pop-up.

For detailed troubleshooting steps, I encourage you to visit our Video Tutorials page for a walkthrough of many different tips. Feel free to search by keyword or toggle through the different videos at the bottom of the page:

SPS Commerce Video Tutorials

If any questions remain, please let us know. Thanks!
Photo of Renee

Renee

  • 122 Points 100 badge 2x thumb
I WANT TO KNOW IF THERE'S AN OPTION TO TURN OFF THE COVER PAGE THAT PRINTS WHEN I PRINT THE ORDERS. The orders print out fine. I do not need to troubleshoot. Clearing cache would not help in this situation. This topic does not belong grouped under this heading. Everything prints fine. I just want to turn off the cover page.
Photo of Hannah

Hannah, Alum

  • 2,370 Points 2k badge 2x thumb
Hi Renee-

I understand you just want to remove the cover page, however, there are many factors that can prevent that from printing. If you already tried changing the printer setting to "all frames individually" and are still receiving the cover page, I am happy to escalate a ticket to our technical specialists who can reach out to you directly. I will send you an email to confirm the contact information we have on file.

Thank you!
Photo of Michelle Nelson

Michelle Nelson

  • 522 Points 500 badge 2x thumb
Mainly, our DSG POs print the last line on a 2nd page. but some others do it as well. its almost as if there is a page break on the PO. it is such a waste of paper and staples... I use internet explorer. is there any way to change this? I have even tried shrink to fit. and it still prints out two pages. not a major issue just a waste I would like to avoid if possible.
Thank You!!!
Photo of Zach Johnston

Zach Johnston, Customer Operations Analyst

  • 570 Points 500 badge 2x thumb
Hey Michelle!

Thank you so much for your response to this post! I was able to print several test POs from DSG and have them print to 1 page using Internet Explorer. Before printing, I ensured that my browser zoom was set to 100% and that my paper size was set to 'letter' in my printer's preferences. Also, are you printing from the print icon on the Purchase Order or from the print option in your browser?

The version of Internet Explorer that you are running may be a factor as well. Let me know if you continue to have issues printing your DSG orders to 1 page and I would be happy to continue troubleshooting that with you. Thanks again!!
Photo of Michelle Nelson

Michelle Nelson

  • 522 Points 500 badge 2x thumb
so I went into IE and changed the margins from .75 to .5 and it worked!!! thank you so much (:
Photo of Julie Lindberg

Julie Lindberg

  • 70 Points
I just switched to Firefox (and updated the new java yesterday) and I am having this same problem of the order being almost "stretched out" -- should be one page (and is in IE) but now is two pages.. But only with Grainger orders. My Fastenal orders are perfectly fine.

Any ideas?
Photo of Michelle Nelson

Michelle Nelson

  • 522 Points 500 badge 2x thumb
Julie;
In my experience with this on our Dicks Sporting Goods orders, In IE, I went into the page setup menu and changed the margins, by widening the margins, the columns widened and allowed more room for the text within them, thus shortening the page length. Also, in Firefox there is the shrink page feature, if I set that at 80% they generally fit on one page. I hope that will work for you. Good Luck :)
Photo of Julie Lindberg

Julie Lindberg

  • 70 Points
Thanks for that info Michelle. I suppose I could try that, but I'm really stumped by the fact that this is only happening with one company's orders.

This conversation is no longer open for comments or replies.